iSkysoft

PDF Editor for Mac

How to Use iSkysoft PDF Editor for Mac

How to Edit Texts in PDF

You will learn how to directly edit PDF text within PDF files. To add, change, or delete PDF text, there are 2 ways:

1) Click the "Edit" button on the toolbar. And then double-click on any text in the PDF file to modify the text within editable text block.

2) Click the "Add Text" button on the toolbar and click on any area on the page you desired to add, modify, or delete text to enter text, correct the error, or click the Backspace to delete text.

edit PDF Text

PDF Editor for Mac comes with an auto-matching system that will match the font for you, making the newly added text exactly the same as the original one. However, you can also select your own fonts. To do so, go to the Format Menu > Show Fonts to select a font, size and typeface.

How to Edit Images in PDF

If your PDF file contains images, you can also make changes on images as you want. To do this, click the "Edit" button to enter the editing state. Then double click on the image to access the image editing options. In the pop-up window, you can choose to crop images, replace images and extract images from PDF. Simply click the option you need to proceed.

edit PDF Text

How to Edit Pages in PDF

With PDF Editor for Mac, you can easily manipulate PDF page and PDF documents. All can be accessed on the right side menu. Just open the "Pages" menu to show all these options and click the one you need. Once you click the submenu, a pop-up will appear, providing you with options to set up before complete the task.

edit PDF Text

How to Mark Up and Annotate PDF

Here you will learn how to markup PDF text and annotate PDF with an array of tools on the Toolbar
  • 1) To markup PDF text, select Highlight, Underline or Strikethrough tool on the top right corner of the toolbar, and then select PDF text to get what you want.
  • 2) To add Sticky Note, Text Box, Arrow, Line, Rectangle, Oval, Polygon, Cloud, and Free-hand Drawings (with Pencil and Eraser), hit the "Markup" button on the top toolbar and then select your desired tool.
pdf annotation

3) To hide and remove markups, you can click the Hide and Remove button on the top right corner of the main interface. And batch remove the unwanted annotations, or hide the annotations to view the PDF in proper way.

pdf annotation

How to Add and Edit PDF Watermark

Watermark helps you spread PDF with your company logo or any text you want. PDF Editor lets you edit standard PDF watermark with 3 tools: Add, Update and Remove. To use these tools, go to the right side and open the "Watermark" menu.

From the submenu, select Add Watermark, Update Watermark or Remove Watermark, and follow on-screen instructions to edit watermark. You can use text, image and even PDF as the watermark in PDF Editor for Mac.

edit pdf watermark

You are allowed to batch add and remove watermarks to multiple PDF documents. Click the "Batch Add" and "Batch Remove" to do productive jobs.

edit pdf watermark

Tips: Click the "Triangle" button at the bottom left corner of the pop-up window, you can access more options for editing PDF watermark, like position, location, appearance and more.

How to Merge PDF Files

With PDF Editor Pro for Mac, you can merge several PDF files into a single PDF. Just go to hit the "Combine Files" menu on the primary window. And then in the pop-up window, click the "Add Files" button to import the PDF files you want to merge. And select or customize the paper size from the "Option" tab. Then, click "Combine" to start merging the PDFs.

merge pdf files

How to Convert PDF Files

To reuse PDF content, you can convert PDF to Microsoft Word with PDF Editor. Simply click the "Convert" button on the top left corner to activate the conversion window.

In the dialog that appears, import the file(s) you want to convert. You can click "Add Files" to import more PDF files to convert, for batch conversion is supported. Choose "Word" as the output format and specify the page range. Click "Convert", and then specify a destination to save the output file. Lastly, click "Save" to start the conversion.

convert pdf to word

How to Create PDF Files

iSkysoft PDF Editor (Pro) for Mac allows you to create PDF documents from many files like Text, Image, HTML, Webpage and existing PDF files. To do so, you can hit the "Create PDF" menu in the primary window and then select the file you want from the pop-up dialog and click the "Open" button to open the file with this editor. Now you can click "File" > "Save as" to save your file in PDF format.

create pdf files

How to Fill Out PDF Forms

iSkysoft PDF Editor for Mac (both Standard and Pro versions) now makes it easier than ever to fill out either interactive or non-interactive forms. The interactive PDF forms will be automatically recognized and highlighted when you open PDF documents with these forms included. Simply click the text field to start filling out your information. For non-interactive PDF forms, go to the top menu bar and choose Edit > Add Text or Markup > Add Text Box, and click the place you want to fill out information then enter texts. You can also export and import PDF form data to fill PDF forms or save PDF form data quickly and easily.

fill out pdf forms

How to Create PDF Forms (For Pro Version Only)

The latest version of iSkysoft PDF Editor for Mac comes with lots of useful tools to help you create PDF forms from templates. This feature takes full advantages of all built-in PDF tools and the form-specific tools like Add New Field (Text Field, Check Box, Radio Button, List Box, Dropdown Menu and Button) and Place Multiple Field. Just open the downloaded PDF form templates with iSkysoft PDF Editor for Mac, and the click the Form button on the top toolbar, and then you can start designing your own PDF forms with the options offered.

create pdf forms

You can make settings to every form field easily. To do so, double click a text field to setting dialog. There you can input the field name, change the default appearance, modify options, validate input data, and so on.

create pdf forms

How to Protect PDF with a Password (For Pro Version Only)

With the help of this PDF editor, you can add a password to protect your PDF document from being opened by others. And you are also allowed to add a permission password to restrict others to access the functions of PDF copying, printing, editing, extracting pages.

You can go to the right side menu, and click the "Protections" tab then select an option according to your needs. In the pop-up window, you can set the passwords.

create pdf files

How to Perform OCR on Scanned PDFs (For Pro Version Only)

iSkysoft PDF Editor Pro for Mac has the ability to convert and edit scanned PDF files after performing OCR. When you open a scanned PDF file, you'll be asked whether to perform OCR so you can edit, copy and search your PDF texts. Select the correct language of your PDF file and click Perform OCR button, then iSkysoft PDF Editor Pro for Mac will turn all PDF texts editable and searchable effortlessly. Alternatively, you can click the OCR button on the top right corner of the interface and then choose an OCR language.

ocr pdf

Note: Once perform OCR, iSkysoft PDF Editor Pro for Mac will save the OCR PDF as a new file. You need to open the new saved OCR PDF to edit or convert it.

Also see the video tutorial on how to use PDF Editor for Mac:

You May Be Interested in These Items

Back to top